datakit安装迁移套件失败
收藏回复举报
datakit安装迁移套件失败
t('forum.solved') 已解决
发表于2024-04-08 10:12:29
0 查看
09:41:47,47 INFO  (ParamsUtils:initMigrationParamsFromProps) - properties = {zkIp=10.16.0.245, java.specification.version=21, sun.jnu.encoding=ANSI_X3.4-1968, java.class.path=/ops/portal/portalControl-6.0.0rc1-exec.jar, java.vm.vendor=BiSheng, sun.arch.data.model=64, path=/ops/portal/, java.vendor.url=https://openeuler.org/, user.timezone=Asia/Shanghai, java.vm.specification.version=21, os.name=Linux, sun.java.launcher=SUN_STANDARD, user.country=US, schemaRegistryIp=10.16.0.245, order=install_mysql_all_migration_tools, sun.boot.library.path=/usr/lib/jvm/java-21-openjdk-21.0.0.35-1.oe2203sp3.x86_64/lib, sun.java.command=/ops/portal/portalControl-6.0.0rc1-exec.jar, jdk.debug=release, sun.cpu.endian=little, user.home=/ops, user.language=en, java.specification.vendor=Oracle Corporation, java.version.date=2023-09-19, java.home=/usr/lib/jvm/java-21-openjdk-21.0.0.35-1.oe2203sp3.x86_64, schemaRegistryPort=8081, file.separator=/, java.vm.compressedOopsMode=32-bit, line.separator=
, java.vm.specification.vendor=Oracle Corporation, java.specification.name=Java Platform API Specification, thirdPartySoftwareConfigType=2, zookeeperPort=2181, java.protocol.handler.pkgs=org.springframework.boot.loader, sun.management.compiler=HotSpot 64-Bit Tiered Compilers, java.runtime.version=21+35, user.name=portal, skip=true, stdout.encoding=ANSI_X3.4-1968, path.separator=:, os.version=5.10.0-193.0.0.106.oe2203sp3.x86_64, java.runtime.name=OpenJDK Runtime Environment, file.encoding=UTF-8, java.vm.name=OpenJDK 64-Bit Server VM, installDir=/ops/portal/tools/debezium/, java.vendor.version=BiSheng, java.vendor.url.bug=https://gitee.com/src-openeuler/openjdk-latest/issues, java.io.tmpdir=/tmp, java.version=21, user.dir=/ops, os.arch=amd64, java.vm.specification.name=Java Virtual Machine Specification, native.encoding=ANSI_X3.4-1968, java.library.path=/usr/java/packages/lib:/usr/lib64:/lib64:/lib:/usr/lib, java.vm.info=mixed mode, sharing, stderr.encoding=ANSI_X3.4-1968, java.vendor=BiSheng, java.vm.version=21+35, sun.io.unicode.encoding=UnicodeLittle, kafkaPort=9092, java.class.version=65.0, kafkaIp=10.16.0.245}
09:41:47,88 INFO  (MigrationConfluentInstanceConfig:getSystemParamAndParseEntity) - get MigrationConfluentInstanceConfig from system param = MigrationConfluentInstanceConfig(id=null, zookeeperPort=2181, kafkaPort=9092, zkIp=10.16.0.245, kafkaIp=10.16.0.245, installDir=/ops/portal/tools/debezium/, bindPortalId=null, zkIpPort=null, kafkaIpPort=null, schemaRegistryIpPort=null, schemaRegistryIp=10.16.0.245, schemaRegistryPort=8081, bindPortalHost=null, thirdPartySoftwareConfigType=2)
09:41:47,88 INFO  (KafkaUtils:changeConfluentDirFromSysParam) - get confluentInstanceConfig success start change param
09:41:47,93 ERROR (PropertitesUtils:changePropertiesParameters) - No such file whose path is /ops/portal/workspace/1/config/migrationConfig.properties
09:41:47,163 INFO  (ParamsUtils:changeDatacheckLogLevel) - global log level param is empty
09:41:47,381 WARN  (FileUtils:outputFileString) - File {} does not exist
09:41:47,381 WARN  (MysqlFullMigrationTool:install) - first check chameleon failed, start install...
09:41:50,321 INFO  (RuntimeExecUtils:unzipFile) - Unzip file /ops/portal/pkg/chameleon/chameleon-6.0.0rc1-x86_64.tar.gz to /ops/portal/tools/chameleon/ finished.
09:41:55,323 INFO  (FileUtils:checkFileExist) - check file exist sleep : 0 s
.....................等待298秒........................
09:46:54,580 INFO  (FileUtils:checkFileExist) - check file exist sleep : 299 s
09:46:54,582 WARN  (FileUtils:outputFileString) - File {} does not exist
09:46:54,583 ERROR (MysqlFullMigrationTool:install) - install failed
IO exception occurred in executing command /ops/portal/tools/chameleon/chameleon-6.0.0rc1/venv/bin/chameleon --version.
Error message: Cannot run program "/ops/portal/tools/chameleon/chameleon-6.0.0rc1/venv/bin/chameleon" (in directory "/ops/portal"): error=2, No such file or directory
File {} does not exist.
    at org.opengauss.portalcontroller.utils.RuntimeExecUtils.executeOrder(RuntimeExecUtils.java:144)
    at org.opengauss.portalcontroller.tools.mysql.MysqlFullMigrationTool.checkChameleonVersion(MysqlFullMigrationTool.java:178)
    at org.opengauss.portalcontroller.tools.mysql.MysqlFullMigrationTool.install(MysqlFullMigrationTool.java:158)
    at org.opengauss.portalcontroller.utils.InstallMigrationUtils.runInstallOrder(InstallMigrationUtils.java:197)
    at org.opengauss.portalcontroller.utils.InstallMigrationUtils.runAllInstallOrder(InstallMigrationUtils.java:211)
    at org.opengauss.portalcontroller.command.mysql.InstallCommandReceiver.action(InstallCommandReceiver.java:32)
    at org.opengauss.portalcontroller.command.ConcreteCommand.execute(ConcreteCommand.java:24)
    at org.opengauss.portalcontroller.PortalControl.main(PortalControl.java:181)
    at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccessor.java:103)
    at java.base/java.lang.reflect.Method.invoke(Method.java:580)
    at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:49)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:108)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:58)
    at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:88)
09:46:57,590 INFO  (MigrationConfluentInstanceConfig:getSystemParamAndParseEntity) - get MigrationConfluentInstanceConfig from system param = MigrationConfluentInstanceConfig(id=null, zookeeperPort=2181, kafkaPort=9092, zkIp=10.16.0.245, kafkaIp=10.16.0.245, installDir=/ops/portal/tools/debezium/, bindPortalId=null, zkIpPort=null, kafkaIpPort=null, schemaRegistryIpPort=null, schemaRegistryIp=10.16.0.245, schemaRegistryPort=8081, bindPortalHost=null, thirdPartySoftwareConfigType=2)
09:46:57,603 ERROR (PropertitesUtils:changePropertiesParameters) - No such file whose path is /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/zookeeper.properties
09:46:57,603 ERROR (PropertitesUtils:changePropertiesParameters) - No such file whose path is /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/server.properties
09:46:57,603 ERROR (PropertitesUtils:changePropertiesParameters) - No such file whose path is /ops/portal/tools/debezium/confluent-5.5.1/etc/schema-registry/schema-registry.properties
09:46:57,621 INFO  (RuntimeExecUtils:executeStartOrder) - start command = /ops/portal/tools/debezium/confluent-5.5.1/bin/zookeeper-server-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/zookeeper.properties
09:46:57,622 ERROR (RuntimeExecUtils:executeStartOrder) - IO exception occurred in executing command /ops/portal/tools/debezium/confluent-5.5.1/bin/zookeeper-server-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/zookeeper.properties.
Error message: Cannot run program "/ops/portal/tools/debezium/confluent-5.5.1/bin/zookeeper-server-start": error=2, No such file or directory
Start zookeeper failed.
09:46:59,636 INFO  (MqTool:start) - kafkaOrder====/ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-topics --list --bootstrap-server 10.16.0.245:9092
09:46:59,653 INFO  (RuntimeExecUtils:executeStartOrder) - start command = /ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-server-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/server.properties
09:46:59,654 ERROR (RuntimeExecUtils:executeStartOrder) - IO exception occurred in executing command /ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-server-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/kafka/server.properties.
Error message: Cannot run program "/ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-server-start": error=2, No such file or directory
Start kafka failed.
09:46:59,655 ERROR (Task:runTaskMethodWithOrder) - IO exception occurred in executing command /ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-topics --list --bootstrap-server 10.16.0.245:9092.
Error message: Cannot run program "/ops/portal/tools/debezium/confluent-5.5.1/bin/kafka-topics" (in directory "/ops/portal"): /ops/portal/tmp/test_.txt (No such file or directory)
.
09:46:59,681 INFO  (RuntimeExecUtils:executeStartOrder) - start command = /ops/portal/tools/debezium/confluent-5.5.1/bin/schema-registry-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/schema-registry/schema-registry.properties
09:46:59,682 ERROR (RuntimeExecUtils:executeStartOrder) - IO exception occurred in executing command /ops/portal/tools/debezium/confluent-5.5.1/bin/schema-registry-start -daemon /ops/portal/tools/debezium/confluent-5.5.1/etc/schema-registry/schema-registry.properties.
Error message: Cannot run program "/ops/portal/tools/debezium/confluent-5.5.1/bin/schema-registry-start": error=2, No such file or directory
Start kafka schema registry failed.
09:47:02,703 ERROR (MqTool:checkStatus) - Start methond=runZookeeper failed.

我要发帖子