---
title: K8s初始化集群加载证书失败的解决方法
description: "初始化集群时提示“failed to load certificate: couldn't load the certificate file /etc/kubernetes/pki/apiserver.crt: open /etc/kubernetes/pki/apiserver.crt: no such file or directory”。"
url: https://www.hikunpeng.com/document/detail/zh/kunpengcpfs/troubleshooting/trouble/kunpengdockerk8s_09_0007.html
sourcePath: /source/zh/kunpengcpfs/troubleshooting/trouble/kunpengdockerk8s_09_0007.html
indexId: df2a525bb425791e0bcf6283edd7721a357fffd3af47f89e9e8f2da1b95890d376
---
# K8s初始化集群加载证书失败的解决方法

#### 问题现象描述

初始化集群时提示“failed to load certificate: couldn't load the certificate file /etc/kubernetes/pki/apiserver.crt: open /etc/kubernetes/pki/apiserver.crt: no such file or directory”。


#### 关键过程、根本原因分析

apiserver.cert由kubeadm组件自动生成，提示此问题是因为环境中的残余配置文件没有清理。


#### 结论、解决方案及效果

删除“$HOME/.kube/config”文件并执行kubeadm reset命令方可解除。
