---
title: 如何打开virt-manager图形化
description: "启动Virtual Machine Manager时提示“Error polling connection 'qemu:///system': internal error: Socket 6378 can't be handled (max socket is 4095)”。"
url: https://www.hikunpeng.com/document/detail/zh/kunpengcpfs/troubleshooting/trouble/kunpengkvm_09_0001.html
sourcePath: /source/zh/kunpengcpfs/troubleshooting/trouble/kunpengkvm_09_0001.html
indexId: dfffee5270c89ee16d2af47931459ea5ca8bd399e9f000f1cd876f96c2b3381170
---
# 如何打开virt-manager图形化

#### 问题现象描述

启动Virtual Machine Manager时提示“Error polling connection 'qemu:///system': internal error: Socket 6378 can't be handled (max socket is 4095)”。


#### 关键过程、根本原因分析

libvirt-4.5.0代码bug导致的问题。


#### 结论、解决方案及效果

升级libvirt版本至libvirt-4.7.0以上，或者修改libvirt-4.5.0源码后重新编译。本节以升级libvirt版本至libvirt-5.6.0为例。

1. 安装依赖包。

```
yum -y install yum-utils rpm-build
```


2. 下载源码RPM包。

```
wget https://libvirt.org/sources/libvirt-5.6.0-1.fc30.src.rpm
```


  本章以libvirt-5.6.0为例，此bug在libvirt-4.7.0版本已解决。

3. 编译安装。

  a. 安装src.rpm源码包。

```
rpm -i libvirt-5.6.0-1.fc30.src.rpm
```


  b. 生成RPM包。

```
cd /root/rpmbuild/SPECS/
yum-builddep -y libvirt.spec
rpmbuild -ba libvirt.spec
```


  c. 安装RPM包。

```
cd /root/rpmbuild/RPMS/aarch64/
yum -y install *.rpm
```


  d. 重启libvirtd服务。

```
systemctl daemon-reload
systemctl restart libvirtd
```
