---
title: 创建Keystone服务出现Proxy代理问题的解决方法
description: "使用openstack命令创建Keystone服务时，出现“ProxyError”问题，提示“Caused by ProxyError(‘Cannot connect to proxy.’,error(104,’Connection reset by peer’))”。"
url: https://www.hikunpeng.com/document/detail/zh/kunpengcpfs/troubleshooting/trouble/kunpengopenstackstein_09_0015.html
sourcePath: /source/zh/kunpengcpfs/troubleshooting/trouble/kunpengopenstackstein_09_0015.html
indexId: 0c98269372e3a5b0bd913d0cd2e3f75ac7e904351e6ce19c72e4e5d76f3ff01581
---
# 创建Keystone服务出现Proxy代理问题的解决方法

#### 问题现象描述

使用openstack命令创建Keystone服务时，出现“ProxyError”问题，提示“Caused by ProxyError(‘Cannot connect to proxy.’,error(104,’Connection reset by peer’))”。


#### 关键过程、根本原因分析

由于配置了Proxy代理，但是openstack命令使用的是http的方式传递，与配置的代理有冲突。所以在执行openstack命令时，必须先关闭代理。


#### 结论、解决方案及效果

关闭proxy代理。

```
unset ftp_proxy http_proxy https_proxy
```
