---
title: Greenplum运行SQL时提示interconnect encountered a network error
description: "使能KAEzip之前，Greenplum运行SQL时提示“interconnect encountered a network error, please check your network (xxx)”和“DETAIL: Failed to send packet (xxx) after xxx retries in xxx seconds”。"
url: https://www.hikunpeng.com/document/detail/zh/kunpengdbs/ecosystemEnable/Greenplum/kunpenggreenplum_kae_03_0024.html
sourcePath: /source/zh/kunpengdbs/ecosystemEnable/Greenplum/kunpenggreenplum_kae_03_0024.html
indexId: cdfad33be4a7ff61c94dff13d15719b871129be76f7200ce172dbda361545ea381
---
# Greenplum运行SQL时提示interconnect encountered a network error

#### 问题现象描述

使能KAEzip之前，Greenplum运行SQL时提示“interconnect encountered a network error, please check your network (xxx)”和“DETAIL: Failed to send packet (xxx) after xxx retries in xxx seconds”。


#### 关键过程、根本原因分析

一般是网络数据包丢失导致的问题。


#### 结论、解决方案及效果

1. 在保证硬件网络没有问题的前提下，尝试大幅度提升操作系统参数“ipfrag_time”、“ipfrag_high_thresh”、“ipfrag_low_thresh”和“ipfrag_max_dist”的值。参考设置如下：
  1 2 3 4 net.ipv4.ipfrag_max_dist = 64000 net.ipv4.ipfrag_time = 6000 net.ipv4.ipfrag_high_thresh = 6710886400 net.ipv4.ipfrag_low_thresh = 671088640

2. 再次运行SQL。
3. 如果还是没有解决问题，尝试将Greenplum的“gp_max_packet_size”参数的值调整到小于服务器网卡默认的MTU值。
  在本例中默认的MTU值为“1500”，因而尝试将“gp_max_packet_size”参数的值调整为“1492”。

  1 gpconfig -c gp_max_packet_size -v 1492

4. 可选：再次运行SQL。
