---
title: 运行
description: "安装Percona完成后，可以进行配置和启动Percona数据库操作，包括修改配置文件、设置环境变量、初始化数据库以及启动和登录数据库。"
url: https://www.hikunpeng.com/document/detail/zh/kunpengdbs/ecosystemEnable/Percona/kunpengpercona_03_0012.html
sourcePath: /source/zh/kunpengdbs/ecosystemEnable/Percona/kunpengpercona_03_0012.html
indexId: e4b7628fa9df01ff8bedbd9d590c59c46f379a63551a34b277d8da53b0ad269c73
---
# 运行

安装Percona完成后，可以进行配置和启动Percona数据库操作，包括修改配置文件、设置环境变量、初始化数据库以及启动和登录数据库。

1. 修改配置文件。

  a. 编辑“my.cnf”文件，其中文件路径（包括软件安装路径basedir、数据路径datadir等）根据实际情况修改。
    1 2 rm -f /etc/my.cnf echo -e "[mysqld_safe]\nlog-error=/data/percona/log/mysql.log\npid-file=/data/percona/run/mysqld.pid\n[mysqldump]\nquick\n[mysql]\nno-auto-rehash\nsocket=/data/percona/run/mysql.sock\n[client]\ndefault-character-set=utf8\n[mysqld]\nbasedir=/usr/local/percona\ntmpdir=/data/percona/tmp\ndatadir=/data/percona/data\ndefault_authentication_plugin=mysql_native_password\nport=3306\nuser=mysql\n" > /etc/my.cnf

  b. 确保“my.cnf”配置文件修改正确。
    1 cat /etc/my.cnf

  c. 修改“/etc/my.cnf”文件的组和用户为mysql:mysql。
    1 chown mysql:mysql /etc/my.cnf

2. 配置环境变量。

  a. 编译安装完成后，将Percona二进制文件路径添加到PATH。
    其中PATH中的“/usr/local/percona/bin”路径，为percona软件安装目录下的bin文件的绝对路径。

    1 echo export PATH=$PATH:/usr/local/percona/bin >> /etc/profile

  b. 使环境变量配置生效。
    1 source /etc/profile

3. 如果选择了通过镜像站RPM包方式安装Percona，则需要执行本步骤以避免初始化数据库失败。如果选择了通过源码编译安装方式安装Percona，则请跳过本步骤。

  a. 下载    rpm-bug.zip压缩包(https://mirrors.huaweicloud.com/kunpeng/archive/kunpeng_solution/database/patch/rpm-bug.zip)
并上传到服务器“/home”目录下。
  b. 解压rpm-bug.zip压缩包。
    1 2 cd /home/ unzip rpm-bug.zip

  c. 进入解压后的文件目录并将其中的文件放入到对应库文件目录。如果有是否重写文件等提示，则输入y然后按回车。
    1 2 3 4 5 6 cd rpm-bug cp libatomic.so.1 /usr/lib64/ cp libstdc++.so.6.0.24 /lib64/ rm /lib64/libstdc++.so.6 ln -s /lib64/libstdc++.so.6.0.24 /lib64/libstdc++.so.6 cp libaio.so.1.0.1 /usr/lib64/libaio.so.1

4. 初始化数据库。
  1 /usr/local/percona/bin/mysqld --defaults-file=/etc/my.cnf --initialize --basedir=/usr/local/percona --datadir=/data/percona/data

  图中倒数第二行红框标记字符je50.Yn&swR<为自动生成的初始密码，请妥善保存。6时会用到。

5. 启动数据库。

  a. 以mysql用户启动Percona服务，执行下面命令后按回车。
    1 2 su - mysql /usr/local/percona/bin/mysqld_safe &

    mysqld_safe脚本会在启动MySQL服务器后继续监控MySQL服务器的运行情况，并在其系统崩溃时重新启动它。 如果第一次启动数据库服务，以root用户启动数据库，则启动时会提示缺少mysql.log文件而导致失败。使用mysql用户启动之后，会在“/data/percona/log”目录下生成mysql.log文件，再次使用root用户启动则不会报错。

  b. 查看Percona进程，mysqld_safe启动时，会同时启动mysqld。

```
ps -ef | grep mysql
```


6. 以mysql用户登录数据库。
  1 /usr/local/percona/bin/mysql -uroot -p

  此处输入的密码为4中生成的初始密码je50.Yn&swR<，请留意初始密码中包含的特殊字符。

7. 配置数据库账号密码。

  a. 修改本地root用户登录密码。本例中密码为"123456"，具体设置以实际规划为准。
    1 alter user 'root'@'localhost' identified by "123456";

  b. 创建全域root用户，允许root从其他服务器访问。
    1 create user 'root'@'%' identified by '123456';

  c. 进行授权。
    1 2 grant all privileges on *.* to 'root'@'%'; flush privileges;

8. 可选：退出数据库。

```
\q
```


  或者

  1 exit
