我要评分
获取效率
正确性
完整性
易理解

Service Startup Failure in Jenkins Pipeline

Symptom

When the compatibility test startup command involves a shell script, using nohup sh shell.sh in the configuration file may cause the target application service to fail to start in a Jenkins pipeline.

Possible Causes

When running the nohup sh shell.sh command, the target application is not started in nohup mode (background startup).

Troubleshooting Procedure

Add nohup to the shell.sh script. You do not need to add nohup when executing sh shell.sh.